Our authentication provider is having issues and some users are unable to login to elvex

Incident Report for elvex

Resolved

This incident has been resolved.
Posted Dec 28, 2024 - 08:54 EST

Monitoring

Our upstream provider has implemented a fix and we're monitoring the results.
Posted Dec 28, 2024 - 08:41 EST

Investigating

We are currently investigating this issue.
Posted Dec 28, 2024 - 08:27 EST
This incident affected: elvex.